HON’s Wiki # Ubiquiti EdgeSwitch
Home / Server
Contents
General
- Default credentials: Username
ubnt
, password ubnt
.
- Serial settings: Baud 115200, 8 data bits, 0 parity bits, 1 stop bit, no flow control.
Initial Setup
Tested with an EdgeSwitch 16 XG, configured as a L2 core/distro switch (homelab).
- Basics (use where appropriate):
- Log in: Username
ubnt
, password ubnt
.
- Enter enable mode (aka. privileged exec mode) from unprivileged mode:
en
- Enter config mode from enable mode:
conf
- Exit any mode:
exit
- Save config:
write mem
- Assume config commands are in config mode, unless stated otherwise.
- Add new user and remove the default:
- Add new user (config mode):
username <username> level 15 override-complexity-check password
(prompts for password)
- Relog as the new user.
- Delete the default user (config mode):
no username ubnt
- Setup basics:
- Set hostname (enable mode):
hostname <hostname>
- Set pre-login banner:
set clibanner "Hello"
- Set timezone (Norway example):
clock timezone +1
clock summer-time recurring EU
- TODO: Verify this.
- Set SNTP server:
sntp server <server>
- Setup STP:
- Set mode:
spanning-tree mode rstp
- Set priority:
spanning-tree mst priority 0 8192
- Enable STP on all ports by default:
spanning-tree port mode all
(default)
- Enable BPDU guard on all edge ports:
spanning-tree bpduguard
- Setup VLANs:
- Enter VLAN mode (enable mode):
vlan database
- Create VLAN (VLAN mode):
- Define:
vlan <vid>
- Name:
vlan name <vid> <name>
- Setup management interface:
- Set management VLAN (enable mode):
network mgmt_vlan <vid>
- TODO
- Setup access ports (untagged edge):
- Enter interface config:
int <range>
(e.g. int 0/8-0/12
)
- Description:
desc host:pve
- Disable flow control:
no flowcontrol
(default)
- Configure LLDP:
lldp receive
(default)
lldp transmit
(default)
lldp transmit-tlv port-desc
lldp transmit-tlv sys-name
lldp transmit-tlv sys-desc
- Configure VLAN (example: VLAN 10):
switchport mode access
switchport access vlan 10
- Configure STP:
- Set as edge port:
spanning-tree edgeport
- (Optional) Enable BPDU filter:
spanning-tree bpdufilter
- Configure storm control:
storm-control unicast level 5
storm-control broadcast level 5
storm-control multicast level 75
- Setup L2 link ports (trunk link):
- Repeat relevant access port config.
- Configure VLAN trunk (example: all VLANs):
switchport mode trunk
switchport trunk allowed vlan all
- Configure STP:
- Enable root guard:
spanning-tree guard root
- Setup AAA:
- Setup (better) local auth:
- Remove any custom AAA commands.
- Avoid enable password:
aaa authorization exec default local
- Setup console:
- Enter line config:
line console
- Set timeout:
serial timeout 60
(mintes)
- Setup SSH:
- TODO
- Set SSH timeout (enable mode):
sshcon timeout 60
(mintes)
- TODO Line enable/authn/authz
- TODO:
- SNMP
- Syslog
- IGMP/MLD snooping.
- MTU
Commands
- System:
- Show hardware and versions:
show version
- Show active and backup firmware:
show bootvar
- L2 interfaces:
- Notice the difference between the
show interface
and show interfaces
commands.
- Show status:
show interfaces status all
- Show traffic counters:
show interface counters
- Show switchport config:
show interfaces switchport [port]
- L3 interfaces:
- Show brief:
show ip int brief
- STP:
- Show summary:
show spanning-tree
Tasks
Reset
- Wait until fully booted.
- Press and hold the reset button for 30 seconds (exact duration is unclear). Holding it for a too short duration will simply reboot the device instead.
Upgrade Software
- Consider whether to use the lite version (limited to 255 VLANS for lower memory utilization).
- Download the new version from the downloads page:
https://ui.com/download/edgemax
- Download the firmware to the backup partition:
copy tftp://<ip-address>/<filename> backup
(example)
- Select the backup partition for the next boot:
boot system backup
- Reboot:
reload
- Verify that the new firmware is booted into:
show bootvar
- Copy the backup firmware to the active partition:
copy backup active
hon.one
| HON95/wiki
| Edit page